Ever So Tweetly

    follow me on Twitter

    Friday, November 30, 2007

    Ma'am, Is Your Car Plugged In?

    Yeah, found out what the problem was with the battery in the car. Seems that when we got the oil changed last, the technicians knocked the cable loose from the alternator.

    I feel like such a doofus, not even checking to see if all the cables were connected properly. *sigh* Thank goodness for free alternator checks at the parts store, right? *sheepish grin*

    I'm still going to take it in and have it looked at though, mainly because Eeyore is still smoking and behaving badly.

    In other news, the phone company cut service to our mobiles, so if you aren't able to get a hold of us tonight, that's why. I spent 1.5 hours on hold, and never talked to a live person, which caused me to miss going to the store and getting Ladybug her costume for spinning poi at the carnival party tomorrow afternoon. I should have the phone problem fixed in the morning, and we're going to have to make do with the costuming.

    At least the car'll get us to tomorrow's events! *grin*

    Lots more prep to do, gotta run!

    (Hey, I posted twice today, look below)

    I am a participant in NaBloPoMo.

    Technorati Tags: Del.icio.us Tags: Flickr Tags: Furl Tags:

    1 comment:

    Rambleman said...

    "Seems that when we got the oil changed last, the technicians knocked the cable loose from the alternator."

    Glad that the problem was found! Cannot believe "professionals" caused the problem. *sigh*